Which devices cannot connect to TrumanSecureWireless?

 

Answer

The list of devices that are supported on the TrumanSecureWireless network is continually growing. A device must support WPA2 Enterprise with PEAP/MSCHAPv2 in order to be able to connect to TrumanSecureWireless. You can find a list below of some popular devices that are known to NOT work on the TrumanSecureWireless wireless network.

To find out if your devices is supported by TrumanSecureWireless, you can lookup it’s wifi certificate on the WiFi Alliance (http://wi-fi.org) product page:

http://www.wi-fi.org/search_products.php

Once you’ve found the device you’re looking for, click on its certificate to find out whether or not WPA2 Enterprise security is supported.

Devices that are known to NOT support TrumanSecureWireless (WPA2-Enterprise)

Kindle Wi-Fi or Wi-Fi + 3G
Xbox 360 S or Xbox wireless networking adapter
Sony Playstation 3 and Sony PSP
Nintendo Wii, DS, DSi and 3DS
Apple TV 1st and 2nd Generation
Nook v1.5
Chromecast
Roku HD/XD/XDS Streaming Player
TiVo Wireless Network Adapter