
 

BASIC WEB PAGES WITH FRONTPAGE 
 
You know you want a web page, and you may even have an idea of what you want to put on that 

page, but the problem remains: how do you make it without learning HTML. There are several 

web page editors available that let you work in a WYSIWYG environment (WYSIWYG, short 

for "What You See Is What You Get," is a style of computer program that allows you to create 

documents for which the on-screen version resembles the output version). There are a few basic 

elements to any web site: text, images, and links, and several formatting options for each. All of 

this and much more can be easily accomplished using Microsoft’s Web Editor - FrontPage. 

 

Two kinds of “web space” – personal and group 
 
Truman maintains a number of web servers. Because they are configured differently to support 

different kinds of users and technologies, it is important to first identify which type of web 

account you are working on – this in turn identifies the server and from there appropriate 

instruction and recommendations can be given to ensure your web works the way you want it to. 
 
Personal Web Space – (Linux OS, Apache Web Server) 
 
There are a number of ways to access your personal web space, see 

http://its.truman.edu/documentation/index.asp?docId=11 for more detailed information. 
 
Configure FrontPage to work with web sites / web pages on Xenon (unless you have specific 

information or technical knowledge to choose otherwise) 
 

1. Launch FrontPage  
 

2. From the Tools menu, choose page options and then select the authoring tab  
 

3. The options there should be filled out/clicked as follows:  
 

a. Browsers – “Both Internet Explorer and Navigator”  
 

b. Browser Versions – “4.0 browsers and later”  
 

c. Select the check box for Active Server Pages  
 
 
 
Group Web Space – (Windows OS, IIS Web Server) 
 
There are a number of ways you can access Group webspace, using FrontPage will give the user 

many control features and scripted options to not only build pages, but manage entire websites. 

In addition, Truman IT Service Center and Web Services staff is most trained on this particular 

web authoring tool. 
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 For step-by-step instructions for opening a web using FrontPage, see: 

http://its.truman.edu/documentation/index.asp?docId=78 


 Configure FrontPage to work with web sites / web pages on the Groups servers (unless 

you have specific information or technical knowledge to choose otherwise) 

1. Launch FrontPage  
 

2. From the Tools menu, choose page options and then select the Authoring tab  
 

3. The options there should be filled out/clicked as follows:  
 

a. FrontPage and SharePoint technologies – “Complete”  
 

 deselect Navigation, Shared Borders and VML graphics 


b. Browsers:  Both Internet Explorer and Navigator  
 

c. Browser Versions:  5.0/6.0 browsers and later  
 

 deselect Frames 


d. Schema version:  Internet Explorer 4.0/Navigator 4.0  
 
 For on-line tips and tutorials on using FrontPage to build and manage websites see: 

 
o http://www.webworkshop.org/ 

o http://www.outfront.net 
 

o   http://www.microsoft.com/frontpage/  
 

 

 For other ways to connect to your web if FrontPage is not available or desired: 

http://its.truman.edu/documentation/index.asp?docId=73 






 For general information about the Group Accounts server, technical capabilities and other 

useful information see: http://its.truman.edu/documentation/category.asp?autoId=12 
 
 
 
 

Using FrontPage – the basics 

 

The following sections deal with the mechanics of actually using FrontPage; how to format text, 

how to layout the page, how to make links, how to add images to a page, etc.. If you encounter 

any technical difficulties, please contact the IT Service Center at 785-4544 / 

helpdesk@truman.edu 
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Inputting and Formatting Text 
 
Text is perhaps the most basic element of any web page. It is the most immediate way to 

communicate your message. In FrontPage, as in Word, one can format nearly every aspect of 

entered text. Some options, such as font face, should be used with caution as not all browsers treat 

such specifications in the same way. Here are several tool buttons to format your text in web-

friendly ways. 
 
Formatting Text Font 
 

1. Highlight the text you want to format.  
 

2. Select one or more of the following toolbar tools to affect the look of your text.  

 

 use the font size tool  to change the size of text. 

 use bold , italic , or underline text tools to change the style of text. 

 use text color tool to change the color of text.  

 use indent  and outdent tools to adjust the left margin of your text. 

 use make numbered list  or make bulleted list for hierarchical text formatting. 

 

 use alignment tools to align the text to the left, right or center of 

the screen. 
 
As you add text to your document, you may notice that when you press the enter key, your lines 

of text are generously spaced (not quite double-spaced, but still generous). If this spacing is too 

wide for your purposes, try holding down the shift key while you press enter. This gives you 

tighter spacing. 
 
 

Note: If the alignment tools listed here are not 

quite enough to control your layout, see the 

section on ―tables‖. 
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Using Graphic Images 
 
While text is arguably the most essential part of your web site, strategic use of graphic images 

can make the difference between dull and dynamic. Using too many or too large an image will 

make your web page slow to load. Using very small images with fine or grainy detail makes 

your page hard to look at. (Remember that the two standard image types used on the web are 

JPEG and GIF). 
 
Inserting an Image 
 

1.   Place your cursor in the desired position. 
 
 

2.   Click insert image tool. 
 

3.   Locate and select the desired file. 
 

1. Click ok.  
 

2. Use the text alignment tools to align your image   
left, right and center on the page. 

 
 
 

 

Adjust/Control the Image 
 
To further control the image after 

placing it, bring up its ―Properties‖ 

box by right -clicking or double-

clicking on the image. 
 
Within this box you can control 

all aspects of the image. 
 

 Text flow around the image 

 Size 

 Space around the image 

 Borders 

 Links (Yes! Images can 

serve as ―hot‖ links) 

 Etc. etc. 
 

Be sure to include an Alternative 

Representation - Text entry. This ―alt 

tag‖ allows the visually impaired to 

―hear‖ your images as they mouse 
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Links are what direct your viewers from one spot to another. Links can be made of images or 

text. There are several types of links to choose from. There are internal links, directing viewers 

from one spot on your page to another (e.g. "back to the top" for longer documents). There are 

links to other pages in your "site," (e.g. a link from your "home" page to your "hobbies" page). 

Finally, there are links from your web page to other people's sites. 
 
Linking to Other Web Pages 
 

1.   Highlight the text or click on the image you want for your link. 

 

 
The Hyperlink  

Sheet 
 

2. Click the link tool; the insert hyperlink property sheet appears.  
 

3. In the ―Address‖ box, type in the site URL (e.g. http://www.truman.edu). (If you are a 

poor typist, use the  
 

―Find URL‖ tool)  

-or- 
 

4. If linking to another 

web page you have 

created and saved in 

the web, select the file 

from the ―Look in:‖ 

location in the middle of 

the property sheet   
5. Click ok  

 
 
Linking Within a Web Page 
 

1. Determine the final destination of your link by placing the cursor there now.  
 

2. From the Insert menu, choose ―Bookmark‖.  
 

3. Name your bookmark in the dialog box.  
 

4. Create the link as normal by highlighting the text or graphic you want to be ―hot‖ (i.e. to 

serve as the jump point).  
 

5.   Click the link tool. 
 

6. Click the ―Bookmark‖ button  
 

7. Choose the desired one and click OK.  
 
E-mail Links (and forms)  
For those surfing on a computer set up for personal e -mail, an ―e -mail link‖ on your page is 

a great feature. Just follow the previous directions for linking to a web page, BUT in the 

―Link to:‖ option box, select ―E-mail Address‖. Enter the desired e-mail in the pop-up box. 
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Important!!! Please note that e-mail links clicked on by visitors will ONLY work if that person 

is at a computer on which a personal e-mail account is locally set up – so if your audience is 

typically going to be accessing your page from a public location like a library or an Internet café, 

e-mail links are not really appropriate and should be replaced with a submittable ―contact form‖. 
 
 

On the groups web servers , Although you are certainly able to use custom scripts, FrontPage 

can help you build submittable forms using built- in form-handling scripts. The links below are 

great resources for exactly how to use/employ this technology. 
 
http://office.microsoft.com/en-us/assistance/HP052617231033.aspx 

http://office.microsoft.com/en-us/assistance/HP052812481033.aspx 

http://www.webworkshop.org/frontpage/forms_tutorial_email.htm 

 

On the personal web server, FrontPage Server Extensions are available if you have activated 

them from the IT Services Webpage. Most of these extensions function exactly like the group 

servers. However, since this machine is not native Microsoft, there are some extensions which 

my not behave as expected. In this case, you may be able to find a script to accomplish the task. 

The links below are great resources for locating free scripts that you can adapt for use on your 

site. 
 
http://www.scriptarchive.com/ 

http://www.bignosebird.com/cgi.shtml 

http://www.hotscripts.com 

 
 

Technical notes for selecting scripts appropriately 
 
 

Server Operating System Web Server Programming 

  Software Languages 

   Supported 

Personal  (Xenon) Red Hat Linux Apache Perl, PHP, ASP 

Groups  (Silver, Neon) Windows 2003 IIS 6.0 Perl, PHP, ASP 
 
 
 
 
 
 
 
 
 

INFORMATION TECHNOLOGY SERVICES 
 

AUTHOR:  DIANE RICHMOND, WEB SERVICES MANAGER  
LAST UPDATED 24 MAY 2006 / PAGE 6 



BASIC WEB PAGES WITH FRONTPAGE 
 
 

Sections and White Space 
 
Text Spacing 
 
As you add text to your document, you may notice that when you press the enter key, your lines 

of text are generously spaced (not quite double-spaced, but still generous). If this spacing is too 

wide for your purposes, try holding down the shift key while you press enter. This gives you 

tighter spacing. 
 

Depending on the version you are using, this ―trick‖ may not be necessary. 
 
 
 
 

Horizontal Rule 
 
Inserting a horizontal rule (line) between blocks of text can help 

divide separate sections of text. To use, simply place your cursor in 

the desired spot and choose ―Horizontal Line‖ from the Insert menu. 
 

You can adjust the height, width, color, etc. of your 

horizontal rule in the Properties sheet.  
(right-click on the rule) 

 
 
 

 

Tables 
 
Perhaps the most widely used ways to control page layout is to place page content within a table. 

This is especially useful if the layout is complex and there is a large amount of text and graphics 

to align. Tables can be nested infinitely, thus providing many ways to divide a page into 

sections. 
 

1. Insert a table by placing your cursor in 

the desired spot.   
2. From the Table menu, choose 

Insert -->Table, this will reveal 

available options in the Table 

Properties sheet.   
3. Set the number of columns and rows 

you want.  

4. Set the width of borders in the table.  
 
 

For really creative use of your space—set the border size to ―0‖, thus making the 

table itself invisible. 

 

INFORMATION TECHNOLOGY SERVICES 
 

AUTHOR:  DIANE RICHMOND, WEB SERVICES MANAGER  
LAST UPDATED 24 MAY 2006 / PAGE 7 



BASIC WEB PAGES WITH FRONTPAGE 
 
 

Altering the Background 
 
Just as you can change the color of your text, you can also change the color of your background 

(just be sure you can read your text against your background). 

 

Adjust your background by 

right-clicking on a blank 

portion of the page. Choose 

the ―Page Properties…‖ option 

 

1. On the Formatting 

tab, in the Colors 

section, click on the 

background color.  
 

2. Choose color in the 

color picker.  
 

3. Click ok.  
 
 
 
 
 
 

 
The Page Properties Sheet 

 
 
 

 

Using an Image as a Background 
 
You can also use an image as the background for a page. This requires even more planning and 

forethought as to the readability of the resultant page. Choose background graphics carefully. 
 

1. Open the Page Properties box by right-clicking on a blank portion of the page (You can 

also reach this box under the Format menu).  
 

2. In the Formatting tab, in the Background section, select the ―Background picture‖ option.  
 

3. Locate the desired file by clicking the ―Browse‖ button.  
 

4. Select the file and click OK.  
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Saving and Previewing... 
 
 
 
 

Saving –  
Get in the habit of doing your initial save immediately after opening a ―new page‖ 
 
 
1. Choose ―save as‖ from the File menu  
 
2. Enter a ―computer-friendly‖ file name for your web page  
 

* Avoid capital letters   
* NO spaces  

 
3. Make sure ―save as type‖ is set to ―Web pages‖  
 
4. Make note of the location to which you are saving!! 

This should be a folder or disk set aside for web 

pre-publishing. Navigate to a suitable location now.  

 

 

By default, web browsers 

automatically display pages 

named ―home‖, ―index‖ or 

―default‖. Naming your main 

page using one of these names 

will simplify your URL by 

eliminating the need to type in a 

filename. 

 
For users who want to get the most out of FrontPage, you should begin working on a web page by first 

using the ―open site‖ command in FrontPage. You can open your files through the ‗Folders‘ view, so 

choosing ―save‖ will save the file into the web which is already open. Some web authors may choose 

to ―pre-publish‖ first—that is save all web pages, graphics, sounds and etc. to a temporary location 

and then publish or transfer all those files to a web server at a later date. 
 

5. Click the ―change title‖ button. This time enter a ―people friendly‖ 

name/description of your web page   
* This is what shows up in people‘s bookmark list   
* Can use spaces, capital letters, and multiple words or phrases   
* Easily changed later in the ―page properties‖ formatting sheet  

 
6. Click the OK button  

 
7. Click the save button  

 
From here on you may simply press the Save button on the tool bar or use the 

key board short cut Ctrl + S 
 
Previewing –  

To try out your page in a browser, preview it using FrontPage‘s built in link to your default browser 
 
1. Be sure to save your page first  
 
2. Press the Preview button on the tool bar  
 
3. Look over your page now displayed in the browser‘s window and try out any links or actions  
 
4. Switch back to FrontPage to continue editing your web page by closing the browser window  
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